What browser versions are NOT supported by the Dognition site?

Browser versions NOT supported by the Dognition site:

  • Internet Explorer 9 and below
  • Safari 4 and below
  • Chrome 20 and below
  • Firefox 14 and below
  • Opera (all)

Keywords: browser, incompatible

Feedback and Knowledge Base